「Artifact required version is ~ and Mule Runtime version is ~」エラーについて

概要

Muleアプリケーションが要求するRuntimeバージョンよりも利用しているAnypoint StudioのRuntimeバージョンが古い場合に表示されるエラーです。

解決法

当該のMuleアプリケーションのmule-artifact.jsonファイルに記載されている「minMuleVersion」の情報を変更することで解決可能です。

①Package Explorerからmule-artifact.jsonファイルをダブルクリックして選択

②minMuleVersionの値を書き換えて保存

■変更例

{
 "minMuleVersion": "4.3.0"
}

{
 "minMuleVersion": "4.2.0"
}

それでも解決しない場合

以下の手順でプロジェクトを再作成してください。

①まずは普通にNewから新規「Mule Project」を選択

②プロジェクト名を入力するこの画面で、Runtimeとして最新の"Mule Server 4.2.2 EE"ではなく"Mule Server 4.2.0 EE"を選択

プロジェクトを作成する時点で古いRuntimeバージョンを指定してあげることで、Muleアプリケーションがデフォルトで要求するRuntimeバージョンそのものを下げることが可能となります。

Mulesoft

Posted by regardie